CorkSport

User Tag List

Page 1 of 2 12 LastLast
Results 1 to 25 of 26

Thread: MPS from Melbourne saying hi

  1. #1
    Bricktop's Avatar
    Bricktop is offline New Member
    Join Date
    Aug 2009
    Posts
    9

    Default MPS from Melbourne saying hi

    Hey guys,

    Just wanted to drop a line and say hi... Been laying low and looking around for a while, thought i'd prop up and say hi...

    Some details about my ride are its an Aurora Blue MPS I have done a few subtle things to it in my time since buying it, It has a BEGI airbox with K&N Filter, the front brakes have all been replaced with DBA Rotors and Hawk Pads with Wilwood Fluid. I put a towbar on for my bike carrier, which i had modified so when its not in use you wouldn't even know its on there...

    I have had a few issues though which have dampened the experience... Clunky front suspension, its been replaced under warranty but still I have had issues with it clunking... The rear swabar end link was ruined and clunking and was replaced. The steering boss came loose and has been replaced. The front CV joints have been replaced under warranty due to a rust build up on the hubs, The rear bumper support was replaced due to rust... this is a very common thing with 3's but you'd never know unless you stick your head under there or install a towbar (like i did)...

    Joining so I can get to the bottom of the clunking cos either it gets fixed or it goes....

    Anyway heres a few pics of my car... Some at Sandown, some at Broadford, some at a photo shoot my brother took ...





    Last edited by armthehomeless; 25-08-2009 at 10:15 PM.

  2. #2
    armthehomeless's Avatar
    armthehomeless is offline Rollin deep in a Lincoln
    Join Date
    Nov 2008
    Location
    Brisbane, QLD
    Age
    36
    Posts
    4,221

    Default

    Welcome

    I fixed your pics so they'd show up

  3. #3
    armthehomeless's Avatar
    armthehomeless is offline Rollin deep in a Lincoln
    Join Date
    Nov 2008
    Location
    Brisbane, QLD
    Age
    36
    Posts
    4,221

    Default

    Is your noise like a knocking noise under the car? Or is it a clunky suspension noise?

  4. #4
    Bricktop's Avatar
    Bricktop is offline New Member
    Join Date
    Aug 2009
    Posts
    9

    Default

    Coming from the left front... down low it happens more frequently when the car is cold... It spent a full week at Mazda trying to fix it. They replaced the front dampers and springs but still made the noise. Mazda had a technician down to try and find it, no joy, this has been going on for months now... Hoping someone around here has a fix, or an idea as to what it is....

  5. #5
    armthehomeless's Avatar
    armthehomeless is offline Rollin deep in a Lincoln
    Join Date
    Nov 2008
    Location
    Brisbane, QLD
    Age
    36
    Posts
    4,221

    Default

    This sounds very similar to my problem. I'm going to try and record the sound.

  6. #6
    Enigma's Avatar
    Enigma is offline Forum Regular
    Join Date
    Jul 2009
    Location
    Kedron, Brisbane
    Age
    40
    Posts
    302

    Default


  7. #7
    240MPS's Avatar
    240MPS is offline I Have The Need For Speed
    Join Date
    Jun 2009
    Age
    52
    Posts
    8,042

    Default

    I hope you sort your issues out, I can't stand the little knocking noises in cars it would drive me nuts...

  8. #8
    CharlieBrown's Avatar
    CharlieBrown is offline Vorsprung durch Technik
    Join Date
    Dec 2008
    Location
    Coorparoo, Brisbane
    Age
    36
    Posts
    3,771

    Default

    to OzMPS

  9. #9
    MISSMPS's Avatar
    MISSMPS is offline "Blame it on my ADD baby"
    Join Date
    Nov 2008
    Location
    northside
    Age
    27
    Posts
    7,812

    Default

    Sexy looking car

  10. #10
    Nirvandan's Avatar
    Nirvandan is offline The Black Hawk
    Join Date
    Nov 2008
    Location
    Brisbane-North-City
    Posts
    5,310

    Default

    Ewwww its a pov pack!!!





































    kidding, kidding!!


    Welcome

  11. #11
    LYNCHY's Avatar
    LYNCHY is offline IS NOT A
    Join Date
    Jan 2009
    Location
    A.C.T
    Age
    28
    Posts
    4,157

    Default



    Looks pretty schmick

    Hope you can solve your clunks

  12. #12
    blackbetty is offline Adios
    Join Date
    Nov 2008
    Posts
    6,403

    Default

    Welcome you car looks so damn clean ... must be an AB thing

  13. #13
    TheJunglist's Avatar
    TheJunglist is offline Reloaded
    Join Date
    Feb 2009
    Location
    Stapylton
    Posts
    2,338

    Default

    welcome to ozmps

  14. #14
    Bricktop's Avatar
    Bricktop is offline New Member
    Join Date
    Aug 2009
    Posts
    9

    Default

    Thanks for the comments guys, the car does get looked after pretty well, have a serious amount of detailing kit at home that i use on it... Usually stick to Menzerna polishes, OCW is used as a wax, I source all my product through Final Inspection, who look after me really well...

    Almost 3 years on and hardly a swirl on it...

  15. #15
    shinslinger66's Avatar
    shinslinger66 is offline Resident Nutter
    Join Date
    Nov 2008
    Location
    Wyong
    Posts
    1,423

    Default

    Was just about to say I know your username from FI...have not been on there for a while and my car is hating me for it!

  16. #16
    YOU LOSE is offline Banned
    Join Date
    Jul 2009
    Location
    cairns fnq
    Age
    69
    Posts
    2,203

    Cool welcome to ozmps club team blu

    your mps looks like it just came off the showroom floor nice .

    Heres my 2bobs worth hope it helps ,
    1. broken engine rear engine mount
    2. exhaust knocking due to above
    3. i have had a clunking problem twice now, every time i went over a bumb in the road, it turned out to be rear shocker lower bolts loose after the second time they locktite,d them and the problem was solved.
    4. if it is a broken rear mount ,and i suspect it is,
    5. you need to replace it with a aftermarket mount .
    6. MPS GARAGE sells them, $225 dollars .They have a web site wwwmpsgarage.com.au they are a mps club sponsor
    I bet the mazda people run for cover when you drive in
    It is no laughing matter i hope you get to the bottom of it ,a shame to have to sell such an awesome car over a minute but annoying problem.
    regards Col

  17. #17
    Bricktop's Avatar
    Bricktop is offline New Member
    Join Date
    Aug 2009
    Posts
    9

    Default

    Thanks for the feedback Col, they checked the mounts but nothing was wrong, didn't trust my local dealer so on my next service i went to pro-maz who looked at the mounts as well and they said the mount was fine, the exhaust is a maybe, it could be... I just have this funny feeling and its not based on anything more scientific than that but it seems to only happen on certain bumps, say going over a sunken manhole or bolt in speed humps... ie: a sharp up and down...

    The car gets used for work and i was hoping to see out the lease and take it on but now i just don't know..

  18. #18
    shakespeare's Avatar
    shakespeare is offline Life Member
    Join Date
    Jan 2009
    Location
    Perth, WA
    Age
    45
    Posts
    6,388

    Default

    Bricktop, great pics hope you solve your clunking, there are lots of knowledgeable, helpful people here!

  19. #19
    Oldhead's Avatar
    Oldhead is offline Forum Addict
    Join Date
    May 2009
    Location
    Sunshine Coast Qld
    Posts
    749

    Default

    Welcome . Lots of info and help from the guys on board. Photos are tops.

  20. #20
    YOU LOSE is offline Banned
    Join Date
    Jul 2009
    Location
    cairns fnq
    Age
    69
    Posts
    2,203

    Smile Fastaz puts thinking cap back on

    OK mate sorry that didn,t help, it has to be some thing that moves when u hit a bump
    1. it doesn,t apear to be front suspension uve had everything checked and replaced
    2. its not engine mounts they have been checked
    3. the exhaust is a likely suspect .check all the rubbers that hold exhaust to the undertray one could be broken or come off the hook
    4. check and tighten all bolts to the rear suspension sway bars /shocks etc also checking all bushes are ok
    5. if the car is still under warranty drop it back and tell them u don,t want it back untill its fixed or replaced .
    6. turn the sound system up to 22 vol lol
    im done Col

  21. #21
    Team Green's Avatar
    Team Green is offline Life Member
    Join Date
    Dec 2008
    Location
    Orange, NSW
    Age
    54
    Posts
    5,149

    Default

    and welcome aboard.....that last pic has some familiar cars that I know.....

  22. #22
    hatchmps's Avatar
    hatchmps is offline Full Member
    Join Date
    Aug 2009
    Location
    The Gap, Brisbane
    Age
    38
    Posts
    83

    Default

    hope you enjoy the forums.

  23. #23
    zippymps3's Avatar
    zippymps3 is offline Senior Member
    Join Date
    Nov 2008
    Location
    Brisbane
    Posts
    358

    Default

    Welcome and enjoy the forum

  24. #24
    Bricktop's Avatar
    Bricktop is offline New Member
    Join Date
    Aug 2009
    Posts
    9

    Default

    Hi all... sorry for the the long absence from posting but getting married and taking a 3 week honeymoon hasn't left me flush with time. Whilst I was away I dropped my car off to the dealership and asked them to look into the noises coming from the front end... 8 days later I get my car back, still with noises coming from the front end...

    What they found was that the front lower engine mount had cracked and the mounting point had deteriorated so badly that the engine was moving as if the was no mount at all, the front left damper had worn again, (despite being replaced 15k ago under warranty) The front left control arm had noise emanating from the lower bush.

    The mount was replaced and I am still waiting for the lower control arm. The problem was they did every replacement one at a time, i.e.: replace the mount, noise still there, replace the damper, noise still there. They flew in a technician from Sydney to look at my car, could not pinpoint the noise, they then got in some sensory based diagnostic equipment and hooked it up to my car, the result was that this whole process left me without a car for 8 days, when I got it back it was covered in bird sh*t... so a less than happy experience. I am still waiting for the control arm to come in, which should be here in about 4 weeks as its coming from Japan on a boat...

  25. #25
    Bricktop's Avatar
    Bricktop is offline New Member
    Join Date
    Aug 2009
    Posts
    9

    Default

    Well after 15 straight days at the dealership and multiple replacement parts, the noise is... still there.

    So I have cut my losses and traded it in. I wouldn't even advertise it due to the amount of stuff that was going wrong. If I did, the first person to see it would have laughed at me due to all the clunking and thumping from the car.

    Here is a list of what went wrong on my car..

    2x CV joints
    4x front struts
    1x rear strut
    2x tie rod end links
    2x engine mounts
    1x steering wheel boss
    1x rear seat headrest
    1x hub carrier
    1x control arm
    1x clutch
    1x turbo seal
    It had 1x mazdaspeed set and 1x MPS seat
    Would never hold a wheel alignment and would have to get one every 2 months

    I traded it for a Ford Mondeo XR5, so I have some parts i can sell such as a BEGI intake and near new Dunlop Sportmaxx's, but i will post that in the for sale parts once I get my post count up..

    So shattered with this car, this was supposed to be my dreamcar and it has just left me feeling shattered and also out of pocket...

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •